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1. Introduction

With its compact form factor, portability, low power consumption, and increasing
processing power, the Android mobile platform is gaining popularity as a
replacement for traditional desktop or laptop computers as a processing platform.
Most digital signal processing algorithms developed at the US Army Research
Laboratory are written in the C programming language to provide sufficient
processing power to satisfy typical processing and performance requirements.
Typical applications developed for the Android mobile platform are written in
Java. Therefore, to achieve maximum speed, there is a need to bridge Java-based
applications to native C applications. Fortunately, a combination of the Android
Native Development Kit (NDK) and the Java Native Interface (JNI) provides such
a mechanism.

NDK is a toolset that allows users to build C/C++ functions into a static or
dynamic library or let the existing prebuilt library be called from an Android
application. JNI defines a way for managed code written in Java to interact with
native C/C++.

This guide is intended to take programmers through adding an NDK package into
an Android Studio Integrated Development Environment (IDE), to building a
simple Android application that calls a C function to add 2 integer values received
from the user screen.

2. Android Studio IDE

This guide assumes the user has already downloaded the Android Studio IDE and
has an extensive working knowledge of this development package. As of the
writing of this report, the version of Android Studio IDE was 1.5.1.

3. Android NDK Package

The Android NDK package can be downloaded via either of the following
methods.

3.1 Method 1

The latest version of the NDK package for one’s operating system can be
downloaded directly from “developer.android.com/ndk/downloads/index.html”.

Expand the package once it has downloaded.

Approved for public release; distribution is unlimited.
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3.2 Method 2

Download the NDK package directly from Android Studio IDE:

1)
2)
3)
4)
5)
6)

Select the “Tools” tab.

Select “Android->SDK manager”.

Select “Appearance->System Settings->Android SDK”.
Select the “SDK Tools” tab.

Check the box labeled “Android NDK”.

Select “Apply”.

Wait for the package to be added into the Android Studio IDE. The downloaded
package can be found at “~/Library/Android/sdk/ndk-bundle”.

4.

Configure NDK with Android Studio IDE 1.5.1

Perform the following steps to configure the NDK with Android Studio IDE,
version 1.5.1:

1)

2)

3)

Set up the Android NDK location:
a) Select “File->Project Structure”.
b) Select “SDK Location”.

c) If Method 1 was chosen, enter the NDK location of where the
downloaded NDK package was expanded. If Method 2 was chosen,
then Android Studio will automatically fill in the NDK location.

Add the JAVAH, NDK-BUILD, and NDK-BUILD CLEAN paths:

JAVAH is a tool provided by Java SE to generate a C header and the
source files that are needed to implement native methods. Refer to
http://docs.oracle.com/javase/7/docs/technotes/tools/windows/javah.html
for a detailed description.

Configure the JAVAH path:

a) Select “Tools->Android->SDK Manager”.
b) Select “Tools->External Tools”.

c) Select “+” at the bottom of the right pane.

d) The “Create Tool” window (Fig. 1) will pop up.

Approved for public release; distribution is unlimited.
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& AndroidStudic File Edit View Navigate Code Analyze Refactor Build Run Tools VCS Window Help

L I B Tue 10:42AM Q
e 0

Create Tool

Name: Croup:  External Tools
Description;

Options.

@ Synchronize files after exacution ™ Open console Outpat Filters...
Show console when standard out changes Show console when standard error changes

Show in
™ Mainmenu ™ Editor meny Project views o Search resuits
Tool setmings
Program:

Insert macro...
Parameters:

Insert macro...
Working directory:

Insert macro...

Cancel 3K

Fig.1  Create Tool window

e) Enter the following to create a path for “javah”, as shown in Fig. 2.

@ Android Studie File Edit View Navigate Code Analyze Refactor Bulld Run Tools VCS Windew  Help o e

“ BF Tue 11:41AM Q=
L] L ] Create Tool
Name javah Greup:  NDK .
Description: | javah
Options
 Syncheonize files after execution ™ Open consale Output Filters...
(¥ Show console when standard out changes [ Show console when standard error changes
Show in
o Main menu o Editor menu o Project views ¥ Search results.

Tool settings.

Program {Library/Java/JavaVirtualMachines jdk1.7.0_80.jdk /Contents /Home, bin/javah Insert macro...

Pasameters: ~classpath $Classpath§ -v -jni SFileClass$ Insert macro...

Working directory: | $5ourcepathEntry$/..jni| Insert macro...
7 Cancel | 0K

Fig.2  “Javah” path

Approved for public release; distribution is unlimited.
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Notes:

e Program: This needs to point to where the JAVAH application is located
on the host.

e Parameters: The parameters are set to -classpath $Classpath$ -v —jni

$FileClass$
0 -classpath  specifies the path for “javah” to look for
classes
0 -v verbose
o -jni tells “javah” to create an output file with JNI-style

native method function prototypes

e Working directory: All the required files needed to create a C callable
object are located in the “jni” directory.

NDK-BUILD is a shell script used to call a GNU “make” 3.81 or later. Use
the following steps to configure it:

1) Configure the NDK-BUILD path:
a) Select “Tools->Android->SDK Manager”.
b) Select “Tools->External Tools.
c) Select “+” at the bottom of the right pane.
d) The “Create Tool” window (see Fig. 1) will pop up.

e) Enter the following to create an environment path for NDK-BUILD, as
shown in Fig. 3:

e Program: This points to the location to where NDK-BUILD is
located.

e Parameters: Leave blank.

e Working directory: This points to where all the Java files are
located.

Approved for public release; distribution is unlimited.
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Group:  NDK

Name nake-build
Description: | nelk-build
Optons
+ Syncheos ites af st + Open I Dutput Fil
o Show ole whes clard hang + Show consale when standard error changes.
Show in
+ Main menu ¥ Editor menu o Project views [ Search results
‘ool settings
Frogram Users {haovu (Libwary Android sk {ndk - bundle) ndic- build

Warking directory: | $PrajectfileDieS fapp/sre fmain

Fig.3  Environment path
NDK-BUILD CLEAN is used to remove all previously generated binaries. Use
the following steps to configure it:
1) Configure the NDK-BUILD CLEAN path:

a) Follow the same steps as if configuring the NDK-BUILD path, except
the parameter is set to “clean”.

b) The final NDK-BUILD CLEAN configuration screen should look like
Fig. 4.

Approved for public release; distribution is unlimited.

5



Name: nidk-build elean Group:  NDK

Description;  ndk=bulld clean

Options
o Synchronize files after execution ' Open console Output Filters.
! Show console when stancard out changes ! Show cansole when standard errer changes

Show in

¥ Main menu (¥ Editor menu (¥ Project views (v Search results

Teol sertings
Program {Users/haowufLibeary] Android fsdk fndk-bundle fndk-build Insert macro...
Parameters: clean Insert macro...
Working directary: | SProjectFileDir$ /app/sre /main Insert macro...

= Cancel oK

L3

27000 | G AndroidMasnor | 13 Terminal Bemtion| ¥ Gragk Console
(2 F: UTF-8: | Contnxt v 8

Fig.4 NDK-BUILD CLEAN configuration
5. Create an Android Application

This guide assumes that the user is well versed in using the Android Studio IDE
to create an Android application. Therefore, a step-by-step guide on how to create
an Android application has not been included. A simple Android application is
provided as an example highlighting the functionality outlined in this report.

A newly created Android application is shown is Fig. 5.

i3
&

e

Fig.5  Android application

The user can then add the ability to read in 2 integer numbers, as shown in Fig. 6.

Approved for public release; distribution is unlimited.
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OWMG &+ XOEE AR ¢ Mifwe-|P ¥ b $@ 8% 7 Q
CoAddTwoNumbers  oape  [Cosre Comain Cjawa [Fleom [ example [ haovu [ addtwonumbers - MadnActivity

®Ee 0= | 5 acuviry_mainoemt x| MalnActr e x

Button btnAdd:
Imanifests EditTexr sditTextA, sditTeaxtl;
Integer inta, inte;
TextView textInfo;

U MR

T3 com. e xamphe hacvu, addiwonumbers
é_ Tl MainActivity gaverride
i * [ com.example. haovu.addwonumibers (androcd o L vold onCreate( e i =
- w Cares super. w:ruwhaweumsmn:tsu\el =
= u . setContentView{R. Layout .activity_main): 2
rawable toxtInfs = [Textview) TindViewByld(R.$d.taxtView); B
¥ b layour btnAdd = (Button)findViewById(R.id.sdabutton);
& = aeaiviny_main.xmi editTextA = [EditText)findViewdyId(A, 1. editTexta);
2 » Eimipmap editTextB = [EditText]findViewByTd(R, id. editTexct);
& BtnAsd . ReTORCLickL istaner (N View.ORCLicklistanar() {
o b [values sirverride
T » (@ Gradie Scripts o public void onClick(View view) {
addTwohiunbers{);
}
s
]
void atdTwohumbers (1
String £ = "'}
ineA = Integer.parselnt(sditTaxed_getTaxt(). tastringi));
intd = Integer.parselntieditTextB.getText(), toStringldl;
Le="A= edntAs B="sintBe N T
El textInto.setText(i);]
¥
F
Andraid Manitor 8- L
L Morarala Nexus 6 Anc ARIE 3] com.example haovu addiwonumbers | ) [DEAD] 2|
& |9 | g memary | i logear | [ITPU <7 gl Neowock - Log tevel: | Verbose 3| (o ) ¥ Regex Show only seiected application | B8
-] T R L UeuLgyEr 13 0w wonyer Bouive
E o |8 1.179 1??86—17?&6;? W‘S\fslm cg;sleaﬂer rel"::enceﬂ unkRoWn path: /fdi PR/ COR. EampLe. haovu. add s-1/lib/am
aEl| C 1.767 17786=17R01/7 D/OpenGLRenderer: Use EGL_SWAP_BEHAVIOR_PRESERVED: trum
* T B4-14 15:59:01, 312 17786-17801/7 I/Adrenc: QUALCOMM build 1 5281442, 18366c00437
bl Build Date T 102801 o
2 OpenGi ES Shader Compiler vnrnen X.EBBL @5.13.92 -
g Local Branch §
Remote Bronch 1
= Remote Branch 1 H
& Reconstruct Branch : g
& B4-14 15:59:01.329 17786-17801/7 I/OpenGLRenderer: Tnitialized EGL, wersion 1.4 3
__E Terminal & Androld Moniar S0 Messages B 4 Run R TODO ¥ bventlog [ Gradle Console
El- sea: d LFTF (6 minutes ago) | R4k LFE | UTF=-B Contear: cnncapterce . | B 3
Fig. 6  Java codes to add 2 integer numbers
To do this, the user must set up a sequence to call a C function from an Android
the “src “directory. This class includes an Android system call to load the
okl @5 & & X [T Ao e o M (feape-| o L Sl LR 7 aQ
- AdMTweNumbers | app Cmain ) java 0 eom 0 examgle  ©0 haovu 7 addtwsnumisess < Nabivelll
T — S o @- |- | S acteiyomainxmd = | £ MainActivityjava = | & Natwslibjava .
§ ¥ Canpp package com.axame Lo, hstvy  dddbwanumbers ™ g
» I mandfests
: v Cajmen -
¥ [ com.example. nacvi.addowoumbers g ‘g
1 R y 4
=] > [ com.axampie.hiovi. AdonumBErE (Sndrod ¥ Systen, loadlibrary{“Nativelib £} =
B8 v Cares z I
5
5 public native int sadiint 11, dnt i2); _
[
"> & Gradu Scries ¥ Fr
public native String holiel); _
3
ARArold MaARSE o L
L Motorola Nexus 6 6.0.1, AP 23 3 ple.h (L7786)[DEAD] 3|
B 5 | Memary | v iogos 0|l CPU | s Netasric ot Log level: | verbess 3| (o | Regex Show only selected application ;| B8
tale B11533 17780 175meys U7y i ElSeaLoadr FoVerenced umkno path e “1/Lin/arm
b B10267 177B6-1TENLST DrDRRrGLReRdnrar: Usn CGL. AP, BEWAVIOR PRESCAVED: 1
o = 181,312 177861786177 I/Adreno: QUALCOMM build ' S2atadz, I8366C0B437
.|, Build Date 1820015 .
Openta = Sl cg iR version: XE031.05.13.02 #
§ ey Fenote Branth ' g
] Romote Branch : 3
i Reconstruct Branch '
) B4-34 15:99:01.329 17786-1THO1/? 1/OpenGLiendarer: Tnitislized £0L, version 1.4 g
W Tesranal |0 Messages B 4 Run 52 TODO T3 Eventlog  (¥] Gradie Conssle
[l Session ‘ape’: Launched an motorola-nexus, 6-ZX1CIILFTP (oday 3:50 PM) AQ [LF: [ UTF-82 | Conmesr <o conteat=_ | W 4

Fig. 7 Native library Java class

Approved for public release; distribution is unlimited.
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o 7. Strecrure. $ Lot & Captares
v

2) Create the JNI directory as shown in Fig. 8, to store all related C source
files and H header files:

a) Select “app->New->Folder->JNI folder”.

b) Select “Finish”. The “jni” directory should appear under the “app
directory.

i ol A @ = M (Fapn- | @ L @ FE AR 7
0 dava 1eom [T example haowu T addtwonumbers  © Nativalib
2 4 LA W actnety_mairiesdd W | © MalnActivi ity Java = | ¢ Matelil java "
packege Com.ex amp Le .. haovu. addtwonumbers |

4=

w

e 3

.-:gi
Ll
£

%]

3
%3

- m_exampl
ai
o

Creates a source root for Java Native Interface files.

Change Folder Location

Target Source Set main

|
The selected folder contains multiple source sets, this can include source sets that do not yet exist on disk. Please select the target source set in which to create = o=
th bd application :

| Cancel wwic Maxt [ Finish |

sote Branch ¥
Renote Branch t
construct Branch

- ncl :
B4-14 15:59:81.329 17786-17881/7 I/DpenGiRenderer: Initialized EGL, wversion 1.4

ool v 3

L]

:
i

W Terminal 4 6 Andraid Monier D:Messages B 4-Run %= TODO Ty Eventlop ¥ Cradie Console

SeRion agp’: Launchad an matorela-nexs, G-ZXLGIZLFTF (4714716, 1-58 PAO BAO LFT [UTF-Bt Confext <op sontest

Fig.8  JNI directory

3) Create the JNI header file using the external tool JAVAH, as shown in
Fig. 9:

a) Select “NativeLib->NDK->javah”:

Based on the Java class created earlier, a header file will appear under
the “jni” directory that has the following naming convention.

e PackageName: com_example_haovu_addtwonumbers

o Followed by the NativeJavaClassname: NativeLib

o Followed by the .h extension

e Example: com_example_haovu_ addtwonumbers_NativeLib.h

b) The newly created header file contains the Java native function
prototypes with the following format:

e INIEXPORT

e  The function return type

Approved for public release; distribution is unlimited.
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e JINICALL

e Java

e Followed by the PackageName

e Followed by the NativeJavaClassname
e Followed by the FunctionName

e Example: JNIEXPORT jint JNICALL Java _com_example
haovu_addtwonumbers_NavtiveLb add (IJNIEnv *, jobject, jint,
jint)

% [l O Mo b [ app ~ | B W O @ $§5 68§ 7
AddTwalumbers app  [sre main Al (5 com_example_haovu_addbwonumbers_Nathvelio.h
o | B Prajec - - 1= | 18 activity_mainxml ¥ | © MaRACEhityjava X | = MativeUbjava % | (2 ap % | [§ com_examale_hacvu_sddtwonumbers_Matvelibn x | [ gradlesropertes
dlv = v Ad
& AddTwolumbers "1 NDK support is an experimental feature and all use cases are not yet supported.
3 » C.gradie
i Jdea 1o <fnd. b
v Ciapp
» [ build
e vifnde! _Included_con_example_heovy_addtwonumbers_lativeLib
5 #define _Included_com_example_haovy_sddtwonusbers_Nativelib
e 3
- Pluspl
» ClandroidTest
= main
£ Java
g com.example. hacvu addiwonumber '
el MainActiny I
r £ 6 NativeUn .
INICALL Java_con_example_haovu_addtwonunbers_Mativel ib_add
1jni 3 =\E
obje iint. janti:
i com_example_haovu_addiwonumbe
i re:
& AndroldManifast xmi
test
qgitignoe
Il app.iml {ICALL Java_com_gxamgle_hacvi_sddtwonunbers_NativeLib_hellc
2 buikd,grad '
proguard-rules. p
gradie
qivgrore
Il AddTweMumbers.iml
= bud.gradie
o gradie. properoes
» /Library/Java/JavaVirtualMachines/jdkl. 7. 8_Bb. jdk/Contents Home/bin/javeh
reating file RegularfileObject [com_example _haovu_sddiwonumbers Nativelib.h]]
5 Process finished with exit code §
3
]
5|
2
a
W Terminal # & Android Monitor @ Messages B &Run “F TODO ¥y Cvent Log # Gradle Consol
[ Gradie bulld finished in 38 GG0MS (moments ago) 5l [LF3 UTF-B% | Context: <no Contexts

Fig.9  JNI header file

¢) Under the “jni” directory, create a C source file (NativeLib_C.c), as
shown in Fig. 10, to implement the native C functions:

i) Select “jni->New->C/C++ Source File”.
i) Enter the filename and type.

iii) Select “OK”.

Approved for public release; distribution is unlimited.
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OHD ¢ XD AR ¢ P muR v $RDR 2 a

| acviny_main a5 | C MainActvityjava x | © Mawvelibgeva % | [B Mstvelb € x| [ Natvelib €5 5 | @ ane x|
NDK support is an experimental feature and all use cases are not yet supported,

| op ¥
. » Couiid 74 Created by haa vw pn 4718716,
(=1 ¥
v [Cisre ;
#inclute h
* Faandn — Anc lud Nativelib C.h
| v CImain
* [Cjava

* [Fcom.example haovu addwonumber
B MainAcTviTy
£ 6 Natveut
* Ejni
(¥ com_sxample_haovu_addwonsmbe
[& nariveLis_C.c
[ MariveLib_€.h

o i

-
& And roidMandestsmi
» Citest
[5] .gmignore
21 app.imi
1 bulld.gradie
1% proguard-rutes.pro

= [ogradie
[E] aignare
91 AddTwolumbers,imi
O pudd gradie
[ gradie.properties
Kun b javah i
» | ¢ /udbrary/Jevasdavavic Jok1. 7.0 88, ), dn/javan ... )
[Creating Tile RegularFilelbiect [com_example_haowi_addtwonumbers Nativelib.hl]
]
e | e Process finished with exit code @
o
g |
" |-
3
e | E -
E. * |
& i
H L
[ Terminal & & Andraid Monitor 5. D Messages = ToDo iy CventLog (¥ Gradie Consale

Fig. 10 Create a C source file

d) Implement the Java native C functions as shown in Fig. 11.

DO ¢4 XS QR &0 HFmb 80l ¥a SRS ? a

[ AddTucNumbers | Capp [sre | [ main [Cn | (£ Nathvelib_€.c |

| [E matelib x| Bagp

E; il fritd i NDK support is an experimental feature and all use cases are not yei supperied.
A £
> Diidea /# Created by hao va on 4718718,
v Ciapp i
* [ buiid
libs #include “com_example_hasvu_sddtwonumbers_MativeLin.h" I
¥ s |8 JNIEXPORT jint JNICALL Java_com_example_haovu_addtwonumbers Mativelib_add{INIEnv =env, jobject obj, jint wall, jint val2){ §
» ClandrowdTest raturn vallsvalld; |
¥ Cimain ¥ !
¥ Cljava

= INIEAPORT jstring JNICALL Java_com_example_hacvu_sddiwonumbers_Wativelib_hello(INIEnv =env, jobject abi
v T COmM.ARNIPU haowy M dDvGrur be ; return(seny)->NewStringleny, “Hello World"};

L R=1]
[ com_example_haovu_addtwonumbe
[& HativeLlb C.c
[¥ MatveLib_C.h
» Chres
= AndroidMardfestxmi
* [Catest
[ gngnose
Il app.imi
(2 bulld gradie
5] preguard-rutes.pro

» Cigradie
[E] .gitignare
D1 Add TwoNumbers.iml
| Messages Gradie Bulld ) oL
m = UP-TO-DATE
= UP-TO-OATE
Ll UP-TO-DATE
r i :appicompieDebuglavaithlavac
3 ‘app:compieDebughdic UE-TO-DATE
= ‘app compiieDebugSources
* i A
- appcompileDebughndroid TestNdk UP-TO-DATE

© BUILD SUCCESSAAL
D Total time;: 0.714 secs

| wmon propuy 4

0 N s =

W3 Dvent Log ] Gradie Consale

Fig. 11 Java native C functions
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e) Modify “build.gradle (Module:app)”:
i) Inside the “defaultConfig” section, add the following pseudo code:

sourceSets {
main{
jni.sreDirs =]
jniLibs.srcDir “src/main/libs”

¥

f) Create an “Android.mk” makefile, shown in Fig. 12, under the “jni”
directory to determine how to build the C code:

i) Select “jni->New->File”.

) Enter “Android.mk” as the filename.

%] X [ Roe D W B P L 3 LA
AddTwoNumbers . [ app = [ src main [ jni - |5 Android.mk
g B Project - #- |- | & activity_mainxml x ¢ MainActivityjava x | © Nativelibjava x | 5| Androidmk x | (& app x | [& com_example_haovu_addwonumbers_Nativelibh x =m
gv = AddTwoNumbers (~/Documents/MyAndroidDev/Ad{  LOCAL_PATH := $(call my—dir) v E
& » [C.gradle 5
5 » idea include ${CLEAR_VARS) ;,
5 v L[Eapp LOCAL_MODULE = NativeLib_(| E
) » [lbuild LOCAL_SRC_FILES := Nativelib_C.c a
& libs =
o v Dsre include $(BUILD_SHARED_LIBRARY) S
. » [landroidTest g
o ¥ [Imain "
2 > java
g v Cljni
= = Android.mk
il com_example_haovu_addtwonumbe
€ Nativelib_C.c
" Nativelib_C.h
> Cares
% AndroidManifest.xml
> Cltest
=| .gitignore
Il app.iml
= build.gradle
=) proguard-rules.pro
» gradle
=l .gitignore
Il AddTwoNumbers.imi
= build.gradle
v gradle.properties
Messages Gradle Build - 2
= app:mergeDebugAndroidTestResources UP-TO-DATE
. app:processDebugAndroidTestResources UP-TO-DATE
2 = app:generateDebugAndroidTestSources UP-TO-DATE
] X app:compileDebuglavaWithjavac
] — app:compileDebugNdk UP-TO-DATE
At = app:compileDebugSources
5 i 4 app:compilel Te
. app:compileDebugAndroidTestNdk UP-TO-DATE
£ app:compileDebugAndroidTestSources >
g BUILD SUCCESSFUL z
= Total time: 1.787 secs g
E 0 errors H
0 warnings a
See complete output in console -
[& Terminal 6: Android Monitor =|0: Messages > 4:Run = TODO T3 Eventlog  [=| Gradle Console
[ Gradle build finished in 15 845ms (today 11:20 AM) 5:27 | nfa | UTF-8% | Context: <no context> 3

Fig. 12 Android.mk makefile

Approved for public release; distribution is unlimited.
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g) Create the “Application.mk” makefile, shown in Fig. 13, under the
“jni” directory to tell the NDK what architecture it should build the
shared library for:

1) Select “jni->New->File”.

i) Enter “Application.mk” as the filename.

= ’ % [ ; ' app ~ | B [y @ §
AddTwoNumbers. app src main Ini
s [ Project - € % | #- 1+ | © activity_mainxml x | € MainActivityjava x | (C Nativelibjava x Android.mk % Application.mk % | (8 app x -=2
‘E v AddTwoNumbers (~/Documents/MyAndroidDev/Ad( APP_MODULES := Nativelib_C
3 » .gradle
» .idea APP_ABI := all
v [mapp
il > Clbuild
& libs
":“' v [Csrc
» [landroidTest
@ v main
= » [Cljava
= > Ejni
~ » [Cdres
V < AndroidManifest.xml
> test
_gitignore
Il app.iml
= build.gradle
proguard-rules.pro
» [lgradie
.gitignore
I AddTwoNumbers.im
= build.gradle
Jigradle.properties
gradlew
gradlew.bat
sl local.properties
= sertings.gradle
Messages Gradle Build
:app:mergeDebugAndroidTesiResources UP-TO-DATE
:app:processDebugAndroidTestResources UP-TO-DATE
2 :app:generateDebugAndroidTestSources UP-TO-DATE
S :app:compileDebuglavaWithlavac
& - :app:compileDebugNdk UP-TO-DATE
~ = :app:compileDebugSources
s i 4 app:compileD 1dTe
) app:compileDebugAndroidTestNdk UP-TO-DATE
A app:compileDebugAndroidTestSources
% ) BUILD SUCCESSFUL
% ) Total time: 1.787 secs
3 @ 0 errors
= @ 0 warnings
@ See complete output in console
Terminal 6: Android Monitor 0:Messages > 4:Run =% TODO T3 Eventlog (=] Gradle Console
[[] session ‘app': Launched on motorala-nexus_6-ZXLG22LFTP (4/14/16, 3:59 PM) 1:27 | nfa UTF-8¢ Context: <no context>

Fig. 13  Application.mk makefile

Note: This application.mk requests the NDK to build a shared library for all
supported architectures. The following details how to build a shared library:

1) Select “app->NDK->ndk-build”:

e A “libs” directory that stores the shared library for all the architectures
is automatically created.

e All the supported architecture directories are created.

e Under each architecture directory, a shared library for that particular
architecture can be found.

Approved for public release; distribution is unlimited.
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6. Final Build and Run Android Application

Perform the following steps to create the final build and run the Android
application:

1) Select “Build->Make Project”.

2) Select “Run->Run ‘app’”.

7. Conclusion

This guide summarizes all the necessary mechanisms and steps to guide a novice
Android application developer to build an Android application that is capable of
handling a high-intensive computation requirement.

Approved for public release; distribution is unlimited.
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