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1. Introduction

While shear bands have been studied for decades using both modeling and
experimental tools, the interpretation and comparison of the obtained data is often
qualitative and has relied upon manual measurements of the observed systems. The
purpose of this report is to document procedures for algorithmically analyzing shear
band morphology that can simultaneously provide a wealth of information, promote
reproducibility, and enable researchers to quantitatively compare complex shear
band phenomena between various materials, conditions, and models. A key feature
of these reported procedures is that the user only needs to provide an image of the
shear bands of interest. This approach mitigates the complications of processing
different data formats produced from various levels of theory and experiment. The
utilization of a shear band morphology quantification methodology that is equally
applicable to molecular simulation, continuum simulation, and experiment is
attractive because of the consistency of the analysis. Furthermore, the sharing,
publication, and archiving of the relevant shear band data is extremely convenient
due to the common image formats. Additionally, previously generated and
published images are candidates for retrospective analysis.

The shear band analysis methods reported here are based on image-processing
methods provided by the open domain software ImageJ' (version 2.1.0/1.53c/Java
1.8.0 172). Image] has existed since 1997 and contains numerous image-
processing and analysis features that can be used to quantify visual data.
Documentation is available online” for the basic features of ImagelJ in addition to
the more sophisticated plugins. ImagelJ also supports the use of custom macros for
defining analysis workflows to algorithmically process data sets. Three-
dimensional data can also be analyzed using ImageJ by providing stacks of 2-D
images. The scope of this report is limited to a handful of features useful for
quantifying shear band morphology.

The approach outlined in this report provides an algorithmic method for analyzing
shear bands across computational and experimental disciplines and is applicable to
past, present, and future work. First, the images are converted to a black-and-white
binary format useful for distinguishing between sheared and unsheared material.
Next, the image may need to be smoothed to reduce background noise in the
sheared regions. Once a black-and-white image with smooth shear band regions is
produced, the morphology of the sheared area can be quantified in terms of the area,
the shear band network structure, and the shear band thickness. An overview of this

* https://imagej.net/
¥ To learn more about ImageJ, consult the documentation or the numerous examples and tutorials
that are available online (https://imagej.net/tutorials/).



approach is illustrated in Fig. 1. The processed image pixel values and the analysis
results can be saved as comma-separated values (CSV) formatted files for further
processing external to Image].

Convert Image to
Black and White

Binary Format

Smooth Shear Area
to Reduce mm Set Length per Pixel
Background Noise

Skeletonize and Compute Thickness

of Shear Bands

Compute Shear Area Compute Shear Band
Branch Lengths

Fig.1  An overview of the steps outlined in this report for quantifying the morphological
features of shear bands using ImageJ

2. Converting to Binary Image Format

The analysis methods reported here rely on a binary classification of either
unsheared or sheared material. Many of the visualization tools used to render
images of simulations or experimental image-capturing devices will produce image
files that possess 16-32-bit depth that allows for a description of image color and
intensity. To convert an image to an 8-bit black-and-white format, perform the
following steps within the ImagelJ software:

1) Select File=>Open . . . and choose the image desired for processing.

2) To use the default, automated threshold identification scheme for binary
classification, continue to step 5. To manually specify a threshold, complete
steps 3 and 4 before proceeding to step 5.

3) Convert the image to an 8-bit format by selecting Image—> Type—> 8-bit.

4) Open the Threshold window by selecting Image—> Adjust—>Threshold. In
the Threshold window, the drop-down selections will be “Default” and
“B&W?” for the left and right options, respectively. Press the “Set” button
and specify a value between 0-255 for the lower and upper threshold level



values. Note that a value of 0 corresponds to black, a value of 255
corresponds to fully white, and any value between corresponds to the gray-
scale intensity. Press “OK” in the “Set Threshold Levels” window. A visual
change may now be noticeable for the selected image. Exit the “Threshold”
window by pressing the X button at the top-right of the window. If more
complex threshold options are desired, please consult the Imagel
documentation for instruction.

5) Select Process—>Binary—>Make Binary to convert the image format to 8-bit
black-and-white. If steps 3 and 4 were followed, a “Make Binary” window
will appear, and all three options will be checked by default. To identify the
shear bands as white, as is the convention in this document, uncheck the last
option that reads “Black foreground, white background” and press “OK.” If
steps 3 and 4 were skipped in favor of using the automatic threshold
identification procedure, then no window should appear when converting
the image to binary format. To check that the image is now in black-and-
white format, hover the cursor over various pixels in the image and inspect
the “value” quantity that is displayed at the bottom of the ImagelJ toolbar
window. All pixel values should be either 0 or 255 and the shear band pixels
should correspond to a value of 255 (white).

3. Smoothing Shear Bands and Filling Small Holes

If the shear band image was produced using data from molecular simulation or
captured from an experiment, there is likely significant noise and image artifacts in
sheared regions instead of a solid white object. The presence of spurious black
pixels in a region that is expected to physically resemble sheared material can skew
shear band area values determined by counting white pixels and can also produce
unphysical, artificial features when analyzing the shear band network properties.
To mitigate this problem, binary image-processing operations can be used to
smooth the shear band features and fill in small holes where the background
protrudes. In Imagel, the binary morphological “Close—" operator can be used to
accomplish this task.* The Close— operator first performs a dilation operation,
followed by an erosion operation. The dilation operation adds pixels to the edges
of objects and the erosion operation removes pixels from the edges of objects.
Because the dilation operation is performed first, some holes are completely filled
in so that edges are not detected during the erosion operation. To carry out these
operations with a user-specified amount of smoothing, perform the following steps:

1) Select Process—>Morphology—> Gray Morphology. A “Parameters” window
will appear.



2) Specify the radius of the structure element, in pixels, in increments of 0.5.
Select the desired type of structure element; circle was used for analysis
shown in this document. For the choice of operator, select “close.” Press
“OK.” The white shear bands should now appear smoother and contain less
black background pixels. Using “Ctrl + z” allows the user to toggle back
and forth between the image before and after the operation to visually assess
the smoothing operation.

3) Iteratively repeat steps 1 and 2 while changing the radius of the structure
element to achieve the desired level of smoothing.

Note that setting too large of a value for the radius of the structure element used in
the smoothing operation will result in the erosion of shear band features. The
smallest possible radius should be used for the structure element that sufficiently
smooths the shear bands and fills in unwanted background noise. In general, several
values of the radius of the structure element should be tested and a sensitivity
analysis performed for all subsequent shear band quantification efforts including
computing the shear band area and the shear band branching characteristics.

Examples of smoothing the shear band images produced from molecular simulation
of RDX pore collapse are shown in Fig. 2. The left panels in Fig. 2 show the
unsmoothed 8-bit black-and-white images originating from molecular simulation.
The right panels in Fig. 2 show the effect of the smoothing process using a circular
element with a radius of 4 pixels. The right panels show sufficiently smoothed shear
bands and have only lost a few small-scale features. If the element radius is
extended to larger values, the shear bands would be overly smoothed and significant
detail in the shear band network would be lost. Ultimately, any choice in the
intensity of smoothing is arbitrary and the user is responsible for thoughtfully
selecting a value.



Fig.2  The two left panels show different shear band structures produced from molecular
simulation of RDX pore collapse; the top-left panel used a weak impact velocity while the
bottom-left panel used a strong impact velocity. The two right panels show the 8-bit black-
and-white images that have been smoothed with the Close— operation using a circular element
with a radius of 4 pixels in ImageJ.

4. Setting the Length Scale and Computing the Sheared Area

After following the steps in Sections 2 and 3 that describe the procedure to produce
an 8-bit black-and-white image, where white represents the sheared material, and
the sheared area has been smoothed and background noise has been reduced, the
area of the sheared material can be determined by counting the white pixels and



establishing a length scale for each pixel. To set the length corresponding to each

pixel and then compute the shear area, follow these steps:

1)

2)

3)

Identify a known distance in the image. A static feature of known length in
the image or even the dimensions of the image itself can be used to establish
a unit of length for each pixel. If no such features are present in the image
of shear bands, a different image containing a known distance can be used
provided it was generated in exactly the same way such that there is zero
ambiguity that the two different images have identical length scales
associated with their pixels. Once the feature with known length has been
identified, use one of the following approaches to measure a distance:

a. Use the “Straight” line segment tool located in the Image] window
to draw a line between two points to compute a distance in units of
pixels. Click on one end point of the known feature and then drag
the cursor to the other end point without releasing the mouse button.
There should be a distance displayed in the ImageJ window that can
optionally be written down. ImageJ should automatically save and
import the distance measured in pixels to the window accessed in
step 3.

b. Alternatively, find the Cartesian coordinates, in units of pixels, of
the feature in ImageJ by zooming in and hovering the cursor over an
end point of the feature and recording the x and y quantities that
appear at the bottom of the ImageJ toolbar window. Repeat this
procedure for the other end of the feature with known length. If the
feature was perfectly aligned with one of the axes, then either the x
or y coordinates should be the same between both pixels. Compute
the distance between the two recorded pixels in units of pixels and
use this information in step 3.

From the Image] toolbar, select Analyze—>Set Scale and a “Set Scale”
window should appear.

Confirm the distance in pixels measured for the feature of known length in
step la or input the distance measured in step 1b, and then input
corresponding distance in units of physical length. Leave the pixel aspect
ratio as 1.0. Change the unit of length to whatever unit of physical length
was provided as the known distance. Leave global unchecked. Press “OK.”
The “Set Scale” window should disappear. Now, the window containing the
image should have information at the top that indicates both the physical
dimensions and the pixel dimensions of the image.



4)

5)

6)

7)

8)

If desired, a scale bar can now be placed on the image by selecting
Analyze>Tools>Scale Bar. A “Scale Bar” window should open and
various options for the scale bar can be specified. Notably, the location of
the scale bar can be positioned anywhere by choosing “At Selection” in the
Location drop-down list. However, a selection must have been made prior
to opening the Scale Bar window. Select the left-most icon on the Imagel
toolbar to use the rectangle selection tool, and then select the rectangular
area, where the scale bar should appear. Then reopen the scale bar window,
fill in the desired values, and press “OK.” The window Scale Bar window
should close, and the scale bar should be present at the desired location.

To ensure that only white pixels are counted in the area measurement, set
the lower and upper threshold levels to both be a value of 255. To do this,
select Image—> Adjust—> Threshold and then when the “Threshold” window
appears, press the “Set” button. A “Set Threshold Levels” window should
appear. Fill in values of 255 for both the lower and upper threshold levels.
Press “OK.” The “Set Threshold Levels” window should close. Exit the
Threshold window by pressing the X at the top-right corner.

To set the desired options for the area measurement, select Analyze—> Set
Measurements. A “Set Measurements” window should appear. The only
two boxes that should be checked in this window are the “Area” and “Limit
to threshold” boxes. Press “OK” and the window should close.

To make the area measurement, select Analyze->Measure and a “Results”
window should appear showing four columns corresponding to the
measurement ID, the area of white pixels in the squared units of length
provided by the user, and the lower and upper threshold limits. If no length
scale was previously set, the area value is in number of pixels. If no
selection is made, the entire image is analyzed. If wanting to compute the
shear area for a specific region, use one of the area selection tools available
in ImageJ and repeat the measurement process. The Results window will
append additional measurements instead of replacing previous values when
the Measure command is reissued.

To export the area measurements, select File>Save As in the Results
window and specify the desired name and location of the CSV file.

The total shear area identified in the image can be used as a metric in a sensitivity
analysis to various image-processing choices. For instance, the sensitivity of the

total shear area resulting from various choices during the smoothing operations that
reduce background noise can be investigated. Figure 3 shows the sensitivity of the



total shear area computed to the radius of the circular element structure used in the
smoothing operations for the left-panel images shown in Fig. 2.
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Fig.3  The sensitivity of the computed shear area to the radius of the circular element used

in the smoothing operations shown for images of RDX pore collapse obtained using molecular
simulation at two different impact velocities (as shown in Fig. 2).

Figure 3 shows that increasing the radius of the circular element will progressively
expand the shear band features and potentially skew the analysis. Between a radius
value of 0-2, where a radius value of 0 is the unsmoothed image, there is a large
increase in shear area that is attributed to the filling in of the background noise with
white pixels in the shear band area. There appears to be no difference between
images smoothed with a 0.5 or 1.0 radius circle. The shear area value computed
using a smoothing circle radius value of 1.5 or 2.0 would likely be a justifiable
choice for smoothing that achieves an optimal balance of eliminating background
noise without excessively bloating the shear band features. However, a handful of
background pixels are still present in the shear band areas when using a radius value
of 2.0 for smoothing. The presence of these remaining background pixels can
strongly affect the analysis of the shear band network and is discussed in
Section 5.

5. Skeletonization of Shear Band Network and Quantification
of Branch Lengths and Junctions

To analyze the shear band network, a reduction of the shear band structure to a
skeletal representation using single-pixel-wide line segments is possible. This
allows for the characterization of shear band junctions and the shear band branch
lengths that connect junctions. This skeletonization process is performed by
repeatedly removing pixels from the edges of objects until reduced to single-pixel-
wide shapes.>® To skeletonize an image, use the following steps:



1y

2)

Select Plugins—> Skeleton—> Skeletonize (2-D/3-D). No additional window
will appear. After some processing time has elapsed, the image window
should now show the skeletonized image. Depending on the extent of
smoothing operations performed according to the steps in Section 3, there
may be significant background residual pixels in shear band regions that
influence the skeletonization algorithm and can lead to spurious features in
the skeletonized image.

To analyze the skeletonized image, select Analyze—>Skeleton—> Skeleton
(2-D/3-D). An “Analyze Skeleton” window should appear. For the prune
cycle method, select “none.” Only check the box that reads “Show detailed
info.” There is an option to eliminate end points by checking the box that
reads “Prune ends.” This pruning option can remove unwanted, artificial
branches that are generated due to noise in the image, but the drawback is
that some desired, physically relevant shear band features may be removed.
A sensitivity analysis should be performed with and without the pruning
option enabled to judge the effect. To illustrate the effect of pruning, the
images shown in the right panels of Fig. 2 were skeletonized with and
without pruning, as shown in Fig. 4. Once the options are selected, press
“OK.” Three new windows should appear.

a. A window entitled “Tagged skeleton” should appear with the
skeleton colored in red. This tagged skeleton window may be
ignored or closed.

b. A window entitled “Results” should appear and list 10 different
columns related to the quantification of the skeletal network. The
first, unnamed column is the Skeleton ID. Different skeleton IDs are
given to each isolated shear band network. Several of these
identified skeletons possess zero or one branches and are likely
caused by image noise. It should be self-evident which skeleton IDs
represent meaningful data and which are noise when inspecting the
number of branches and the average branch length.

c. A window entitled “Branch information” should appear and contain
12 columns. This window contains the individual data of every
branch of each identified skeleton.

3) To save all the available skeleton data, perform a File—>Save As operation

in both the “Branch information” window and the ‘“Results” window to
generate two separate CSV files. These CSV files can then be processed
externally from ImageJ.



Fig.4  The images of weak (top) and strong (bottom) impact from the right panels of Fig. 2
were skeletonized with and without pruning the end points, as shown in the right and left
panels of this figure, respectively. While pruning the end points is seen to be effective for
removing short, artificial line segments that were generated because of noise, there is also the
removal of physically relevant features. As such, care should be taken in deciding whether
pruning the end points is more helpful than harmful for analyzing the shear band network.
The skeletonization of the shear bands results in lines of single-pixel thickness, which may
require visualizing under high resolution.

Examples of types of analysis that could be performed on the skeleton data of the
shear band network are shown in Fig. 5. Distributions of skeleton branch lengths
are shown in Fig. 5, which correspond to the panels in Fig. 4. Comparing the
distributions from skeletons without end-point pruning to those with pruning shows
that the pruning operation significantly reduces the occurrence of short branches.
As exemplified in the bottom-left panel of Fig. 4, many of the short branches in the
skeleton dangle off longer branches and are likely artificial constructs rather than

10



important shear band features. This would justify the use of the pruning operation;
however, Fig. 5 also indicates that several of the long branches that are between 20
and 35 nm in length were removed during the pruning process. These long branch
features are most likely significant shear band features that should be included in
the analysis, therefore complicating the decision of whether to use the end-point
pruning option built into Imagel. It is possible to write custom ImageJ macros or
externally process the unpruned skeleton data to better remove artificial branches
from the skeleton, but these efforts are outside the scope of this report.
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Fig.5  Distributions of skeleton branch lengths of the shear band networks shown in Fig. 4.
The effect of pruning vs. not pruning the end points of the skeleton are shown in the right and
left columns, respectively.

6. Computing the Thickness of Shear Bands

The thickness of shear bands can be calculated by determining the largest circle or
sphere, depending on dimensionality, that fits inside the object and is centered on
the pixel for which the thickness is being calculated.” In this manner, every pixel of
a shear band object can have a thickness associated with it. While this process
provides a wealth of information, a reduction in dimensionality can be useful for
summarizing the thickness of shear bands. Typically, the largest circle that can fit
within the shear band and be centered on the pixel at the midpoint of the shear band
is of interest. To perform this analysis, only the shear band skeletal pixels,
determined using the process outlined in Section 5, are considered when reporting
the thickness of shear bands. The following steps outline the approach to compute
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a distance map for the thickness of the shear bands, and to reduce the data set to

only the skeletal pixels of interest:

1)

2)

3)

4)

5)

6)

Follow the steps in Sections 2 and 3 to produce a shear band image that is
8-bit black-and-white and has minimal background pixels in the shear band
regions (see Fig. 6b).

From the ImageJ window, select Analyze->Local Thickness=>Geometry to
Distance Map. A window entitled “EDT . . . ” should appear. Set the
threshold value to 255, leave the inverse case box unchecked, and press
“OK.” The EDT window should disappear, and a new image window should
appear showing the shear band thickness as intensity using the “Fire” color
gradient (see Fig. 6¢).

Click back to the 8-bit black-and-white image window and then skeletonize
the image using step 1 given in Section 5 (see Fig. 6d). If desiring to prune
the end points of the skeletonized image, follow the relevant instructions of
step 2 given in Section 5 (see Fig. 6¢).

Change the intensity of the white pixels in the skeletonized image from a
value of 255 to a value of 1 by selecting Process=>Math—>Divide. A
“Divide” window should appear. Set the value to 255 and press “OK.” The
Divide window should close, and the image should now appear to be black
due to the white pixels now having a value of 1. While not necessary, the
cosmetic appearance of this image can be recovered by selecting
Image—> Adjust-> Brightness/Contrast, pressing the “Auto” button in the
“B&C” window that appears, and then exiting the B&C window.

To use the skeletal image to reduce the thickness information generated,
select Process—>Image Calculator. A window entitled “Image Calculator”
should appear. In the “Imagel” and “Image2” drop-down lists, select the
skeletonized image with white pixels set to a value of one and the distance
map image that should have an “ EDT” appended to the original image
name. It does not matter which image is “Imagel” or “Image2” as long as
both images are selected since the operation to specify is “Multiply.” Make
sure that the “Create new window” box is checked and leave the “32-bit
(float) result” box unchecked. Press “OK.” The Image Calculator window
should disappear and a new image window should appear and display the
skeletal structure with a gray-scale gradient that corresponds to the
thickness of the shear bands (see Fig. 6f).

To export this thickness information for external processing, select
Image-> Transform—>Image to Results. A “Results” window should appear

12



with zero-indexed rows and columns that correspond to the dimensions of
the image. Each cell contains a pixel value that is the length from the middle
of the shear band to the edge of the shear band, in units of pixels. Save this
information to a CSV file by selecting File>Save As in the Results
window.

7) To assign a physical length to these units when processing the data external

to ImagelJ, simply multiply each value by the length per pixel value that can
be determined by the steps provided in Section 4. Note that the data
exported in step 6 is the half-width thickness.

Fig. 6 Examples of different stages of image processing for shear band thickness
quantification of the strong impact simulation. (a) The original image; (b) the original image
converted to an 8-bit black-and-white format with smoothing operations; (c) the distance map
showing thickness information for every shear band pixel; (d) the unpruned skeletal image;
(e) the pruned skeletal image; and (f) the image resulting from multiplying the pruned skeletal
image with the distance map. The skeletonization of the shear bands in d—f results in lines of
single-pixel thickness, which may require visualizing under high resolution.

The thickness data, illustrated in Fig. 6f, can be used to inspect shear band
distributions, such as those shown in Fig. 7. As with previous analyses mentioned
in this report, it is important to perform a sensitivity analysis of all results to the
smoothing operation settings used in Section 3 and whether or not the skeletal end
points are pruned.
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Fig.7  Shear band thickness distributions resulting from collapse of an RDX pore initiated
by a strong impact. (left) The distribution corresponding to the unpruned skeletal structure
shown in Fig. 6d; (right) The distribution corresponding to the end-point pruned skeletal
structure shown in Fig. 6e.

7. Conclusion

Detailed, step-by-step procedures have been provided for quantifying
morphological features of shear bands such as the total sheared area, the branch
lengths and junction location of the shear band network, and the shear band
thickness values. While the examples of analysis were only given in the form of
distributions of the branch lengths and thickness values, it is also possible to inspect
the spatial correlations of such data. Given enough shear band images to provide
high-quality statistics, it may be possible to inspect the radial distribution of shear
band features, such as junctions in the shear band network. This information can
then be cast into reciprocal space by use of a Fourier transform to better quantify
the periodic structures that emerge. Commentary was provided throughout the
report about performing sensitivity analysis regarding the image-processing
choices that are made. While this report focused on processing 2-D data, the
analysis techniques used in ImagelJ are capable of processing 3-D data provided in
the form of stacks of 2-D slices.
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2-D two-dimensional

3-D three-dimensional

ARL Army Research Laboratory

CSv comma-separated values

DEVCOM US Army Combat Capabilities Development Command
ID identification

RDX 1,3,5-Trinitro-1,3,5-triazinane
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