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I.  Introduction: 
 
The Intelligence Analyst Associate (IAA) is a software program, developed by Veridian 
and sponsored by AFRL/IFED, to aid Intelligence Analysts with the task of deriving 
information from text documents.  IAA takes text documents and uses natural language 
understanding to extract relevant data from those documents.  This extracted data may 
then be searched through for specific terms or concepts that the user requests.  The results 
from this search can be visualized in four different manners, and from each of the 
different visualizations the results can be traced back to the original text document. 
 
The architecture as seen by the user is pictured in Figure 1.  This flow-chart shows how 
the different functions, or tools, in IAA operate together.  Documents are selected for 
loading and extraction.  The extraction process takes the text documents selected by the 
user and, using natural language understanding technology, takes key words in the 
sentence structure and places them in a database for querying.  During extraction, the 
processing status of each document may be viewed from the Extraction Process Status 
tool.  The processing status is shown in a table, with each row representing a document.  
Each column holds a specific process in the extraction, and in that process each document 
is either PENDING, RUNNING, or is SUCCESS-ful.   
 
After extraction, the data may be queried using the Query tool, which allows the user to 
enter terms or concepts from the Term Organization tool as criteria for the search.  The 
Term Organizations, which are usually created prior to using the Query tool, hold terms 
the user has entered in a hierarchical structure.  Any group (organization) in this structure 
may be used in the query as criteria.   
 
When the query has been run, the results may be viewed with the Analysis and 
Visualization (A&V) tools.  These tools show the results in different manners—as a table 
of information from each result, as columns of statistical information on how many times 
a particular word or phrase appeared in the results, as points plotted on a timeline, and as 
points plotted on a world map. The A&V tools can send the query results to any other 
A&V tool, and each A&V tool can access the Document Browser, which shows the 
document a result came from in its entirety. The query may be saved from the Query 
Development or any of the Analysis and Visualization tools. 
 
The primary goal for this summer’s work was to develop a new Main Menu for the IAA 
program.  The new Main Menu needed to be more intuitive and user-friendly.  Also, it 
needed to be larger.  With these guidelines in mind, as well as suggestions previously 
collected by a survey of intelligence analysts who have used the program, a new Main 
Menu was designed and developed. 
 
Along with designing the new Main Menu interface, a User Manual update and Trace-
Through of the program were developed in regards to the new Main Menu.  The User 
Manual update gives a basic overview on using the Main Menu and is intended to replace 
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the section on the Main Menu in the existing User Manual made by Veridian.  The User 
Manual is included as Appendix A. 
 
The Trace-Through is intended to aid the user by giving an example of how to use IAA.  
Starting from the Main Menu, the Trace-Through gives step-by-step instructions on how 
to load documents, create term organizations, perform queries, view query results, and 
save query structures.  The Trace-Through is included as Appendix B.   
 

 
Figure 1: IAA User Interface Flow-Chart 
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II.  The Original Main Menu 
 
The original Main Menu is depicted below in Figure 2.  As can be seen in the picture, the 
Main Menu is small, and can be confusing.  There is no indication for the beginning user 
of how to go about using the program.  When presented with this interface, the beginning 
user wouldn’t know what to start with.  The icons are confusing and the button names 
aren’t very descriptive.  Also, when many tools are open (each tool opens in its own 
frame) the Main Menu tends to “get lost” behind all the tools. 
 

Figure 2: Original Main Menu Interface 
 
III.  Main Menu Upgrade: 
 
This summer a new Main Menu for IAA was designed.  It is shown in Figure 3.  The new 
Main Menu is larger than the previous menu, and allows for a much more intuitive use of 
the program.  The IAA tools are grouped by function and in order they should be used.  
 
Features of the new Main Menu include: 
• When the mouse is over a button, a description of that tool appears on the bottom of 

the screen in the Comments section. 
• The Term Organization, Query, and Notebook tools may have multiple displays 

open at one time.  In order to organize these tools, they may be hidden in the drop-
down list under the tool’s corresponding section of the Main Menu.  Comments 
added by the user for each display may be viewed by selecting the tool name from 
the drop-down list.  These comments also appear in the Comments section on the 
bottom of the Main Menu. 

• Help is available on each tool, as well as on the Main Menu.  The Help for the Main 
Menu gives an overview of how to use IAA. 

• The Analysis and Visualization tools are only available if there is a query in the 
Query Development drop-down list.  Otherwise, they are grayed out.  The A&V 
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tools, when accessed from the Main Menu, will open up with the results from the 
query currently selected on the list.  

 

 
Figure 3: Main Menu 

 
The tools (functions) of IAA will, for the most part, remain the same.  Each tool, 
however, will be placed in a frame that holds two or three buttons (depending on the 
tool).  These buttons will access help for the tool, close the tool display, and with Term 
Organizations, Query Developments, and Notebooks, hide the tool in the drop-down lists.  
An example of this frame is pictured in Figure 4.  The tool will appear in the middle 
(where the picture is), and the frame will stretch or shrink to accommodate the tool’s size.  
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Figure 4: Tool Frame 

 
 
IV.  Recommendations for Future IAA Development: 
 
While IAA is a very useful tool to have, its interface often presents problems with the 
users.  The program would be easier to use if it was simplified.  Here are some 
recommendations on improvement, ordered by tool: 
 
• Login: 
 After the user types in the password, hitting the enter key should do the same as 

clicking the “OK” button. 
• Main Menu: 

Have the Load Documents and the Load Status buttons combined to one Loading 
Documents button (see Loading Documents below). 

• Loading Documents: 
The Loading Documents interface displays information about the progress of the 
information extraction process on documents that the user has chosen to load.  
The Add Documents button on the bottom will open up the Load dialogue box. 

Query Development 1 
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• Term Organizations (Concept Domain Manager):  
*See below for further suggestions.   

• Saved Query Results (Topic Areas): 
*See below for further suggestions. 

• Query Tool: 
Change the “Entity” buttons to say: Subject Type, Object Type, or Term Type 
(Any Field), so that the user would have more of an idea what that button does.  
The “Concepts” button should be changed to “Term Groups”. 

• Analysis & Visualization Tools: 
All the A&V tools should have a similar look to them (the Geo Display and the 
Timeline display are very different).  All tools should have a Records (File?) 
menu in which the user can save and save as the dataset, send records to another 
tool, and exit the tool.  This would replace/rename the DataInfoSet menu on the 
Statistics and Data Browser.  When records are sent from one tool to another, 
unless no records are selected the program should ask if the user wants to send all, 
selected, or view document. 

 All the A&V tools should have the same closing question (Confirm Exit). 
The popup menu to send records to a tool should have no tools already selected 
and should explain more clearly what simple events, sentences, and named 
entities mean in terms of data displayed. 
 Data Browser: When the columns are resized, when the browser is reopened 

they should remain the changed size. 
 Statistics: When a column is resized, the rest of the columns should adjust 

position accordingly.  Also, the columns should be able to be tied together 
somehow (these 2 things appeared x number of times in the documents) and 
there should be an option for the user to organize things by document (how 
many times this particular thing appeared in this particular document). 

 Timeline:  In the group by list box, is the ability to type into the text field 
necessary or should the user just be limited to choosing from the list?  Are all 
the menus (Annotations, Customize, Edit) necessary?  And the summary 
popup information (after plotting) should be given focus until the user clicks 
“OK” so that the display doesn’t get hidden behind the timeline. 

 GeoDisplay:  The Plot Inferred Locations question should come up after the 
map is displayed.  It keeps getting hidden behind the map and the map must 
be minimized in order to plot the locations.  Also, are all the menus (Edit, 
Mapping, Tracking, Satellites, Applications) necessary? And the summary 
popup information (after plotting) should be given focus until the user clicks 
“OK” so that the display doesn’t get hidden behind the map. 

 Document Browser: An Edit menu should be added on the menu bar, or the 
choices to select all and to copy selected items to the clipboard, where they 
can be pasted onto a notebook page.  The “Dismiss” option on the File menu 
does nothing.  Perhaps it should be removed. 
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• Notebook:   
The notebook should open the system’s main text editor program (Notepad, Text 
Editor) where analysts can send documents or parts of documents to make notes 
on, and then save to a folder or send elsewhere. 

 
 

 
Figure 5: Current Concept Domain Manager 
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* Term Organizations (Concept Domain Manager) Suggestions: 
The current Concept Domain Manager (renamed Term Organizations in new Main 
Menu), while it doesn’t look all that complicated, is difficult to use.  Adding groups and 
terms takes several steps and opens several screens that can become lost if the user clicks 
on an area in the original screen.  Figure 5 shows a screenshot of the current Concept 
Domain Manager.   
 
One suggestion on improving it include allowing the user to type in directly what they 
want the node to be instead of having to right-click, select, then type.  Based on this 
suggestion, a new Term Organization was designed as a suggested solution.  This Term 
Organization design, which has not yet been developed, is pictured below in Figure 6.    
 

 
Figure 6: New Term Organization Design 

 
In the new design, right clicking on a group will display a menu with the options to add 
categories, rename, delete, and hide/show instructions.  When the instructions are hidden, 
the Group and Term sections fill the empty space.  The file menu holds the new, open, 
save/as, close and delete organization, and exit properties.  The Options menu holds all 
the capabilities of the right-click menu, as well as Export Categories and Find Term. 
Adding terms in the new design will be accomplished by selecting a group name to add 
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the term to, and then typing the term under the Terms section.  Each term will be on a 
single line, and if the term list becomes larger than the display the display will scroll. 
 
*Saved Queries (Topics) Suggestions: 
The current Topics interface (renamed Saved Queries on the new Main Menu) is also a 
very confusing interface.  Saving queries or results involves moving files from a 
temporary to permanent place before the file will be saved.  Also, there is no way to view 
relevant information about a query or result.  The information currently viewed when the 
user clicks on a query is confusing and not of much use. The user must really know the 
program to be able to utilize this interface, as it is not very intuitive. The current Topics 
interface is depicted in Figure 7 below. 
 

 
Figure 7: Current Topics Area screen 

 
Due to the confusing interface, a new Saved Queries interface was designed, but has yet 
to be developed.  This interface appears in Figure 8. 
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Figure 8: Suggested Design for Saved Queries 

 
In the new interface, the structure of the query will be saved, not the results.  Each query 
saved will open the query tool so that the user can change the document group to query a 
new set of data.  The user will also be able to view the results of the original query (on 
the original document group) in any of the Analysis and Visualization tools without 
having to run the query (directly) again.  The user can rename the, but the default name 
for the results and query will be the same as it is now.  Recommended names for the 
results would be the name or date of the document group queried.   
 
The toolbar buttons stand for different functions, some of which in the current tool 
require two or more steps to access.  X is exit, A&V sends the results to an A&V tool 
(opens up the current Send Dataset dialog box which allows the user to choose the which 
tool to open and the type of data sent), and Q opens the query tool with the selected query 
set up.  New Folder creates a new folder to organize queries into a hierarchical 
organization. The cut, copy, paste, delete (Del) and undo options are also on the toolbar 
to help organize the queries into a hierarchical structure.  The A&V and Q buttons will be 
grayed out unless a result or a query is selected. 
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Selecting a Query will cause the summary (information that created the query) to appear 
in the Information section.  Right clicking on a name in the Queries section will cause a 
menu to appear that allows the user to rename, cut/copy/paste, delete the item.  Double 
clicking will send a query to the query tool.   
 
The File menu holds the Exit option, Edit holds the New Folder, Rename, Cut, Copy, 
Paste, Delete, and Undo options, View allows the user to expand or collapse all folders 
(and queries), and Tools opens the Query tool or the Send Dataset dialog (the A&V 
tools). 
 
The user can enter comments about the items by right clicking (on the menu that appears) 
or under Edit or by a button on the toolbar.  A dialog box will be displayed that has a 
textbox in it for the user to enter the comment into or change the current comment.  The 
comment will be displayed on the Information section. 
 
The program will take any saved results that haven’t been viewed in x amount of time 
(days, weeks, etc.) and ask the user if it’s ok to delete those saved results.  The user can 
set the amount of time between asking, and if the process is automatic or if it needs the 
user’s permission.  These options will be under the File menu.  
 
V.  Summary: 
 
The technology behind Intelligence Analyst Associate, and most of the tools of the 
program, is extremely useful to intelligence analysts.  However, the Main Menu, Term 
Organization, and Saved Queries interfaces are extremely confusing for users just starting 
to use the program, and even for users experienced with the program.  Through 
suggestions from analysts and using the program, new interfaces for the three tools were 
designed, and the new interface for the Main Menu was developed.  Other suggestions 
were also made in the hopes of improving a promising program.  
 
The new Main Menu consists of many features intended to make it easier for intelligence 
analysts, or anyone, to use.  The features include separation of tools from other functions 
(Help, About, Exit), and separation of tools into chronological order of use.  Tools may 
be managed better due to the new Current lists under the Tool Organization, Query 
Development, and Notebook sections.  The Notebook tool offers a basic text editor 
within the program that can be used by the user to hold notes about a specific query.  
Additional help is available through mouse movement, and through the Help button on 
each of the tools and the Main Menu.   
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Appendix A 
User’s Manual 
 
Main Menu: 
 The main menu is where all the functionality of IAA may be accessed.  It is 
divided into two main sections, and each section is divided into three subsections, in 
order to organize the functionality of IAA into an ordered process.   
 Setup and Extraction Processes: 
  Load and Extraction Processes: 

 Load Documents—This button opens a dialog from which the 
user chooses files or directories to extract information from.  
The extraction process runs in the background so that the user 
can take care of other tasks on the computer. 

 Extraction Process Status—This button displays a table that 
shows where documents are in the extraction process.  From 
this display documents may be removed from the process. 

  Term Organizations: 
 New/Saved—This button opens up a new Term Organization 

screen from which old organizations can be retrieved.  In the 
display, words can be organized into different categories, all 
under four main categories (Entities, Actions, Attributes, and 
Concepts), to make querying the data extracted from the 
documents easier. 

 Current—This drop-down list holds all the Term Organization 
displays that were hidden (not closed).  To open one, select it 
from the list and click the “Open” button next to the list.   

  Previous Queries: 
 Saved Queries—This button opens up a display where saved 

query structures (from the Query tool) can be organized and 
opened. 

 Search Processes: 
  Query Development: 

 New Query—This button opens a new Query Development 
display where the user can enter terms or phrases to search for.  
Term organizations, or parts of them, may also be used as 
query criteria. 

 Current—This drop-down list holds all the Query Development 
displays that were hidden (not closed).  To open one, select if 
from the list and click the “Open” button next to the list. 

  Analysis and Visualization Tools: 
The A&V tools allow the user to view the query results in a variety 
of ways.  The tools are accessible in the query tool itself, and the 
buttons on the main menu are only activated if there is at least one 
query hidden in the Query Development Current list.  When 
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pressed from the main menu, the A&V tool selected will open for 
the query development currently selected in the Current list. 
 Data Browser—This tool displays the query results in a table 

format.  Depending on the type of data sent to it, different 
columns appear in the table for each piece of data. For 
example, if sent Extracted data, there will be a column for 
subject, direct object, etc., for all query results.  Each row 
represents a sentence or clause from the queried data. 

 Statistics—This tool displays columns of data that show how 
often the particular term or phrase appears in the query results.  
The columns to be shown (which correspond to the columns in 
the Data Browser) are chosen when the tool is first opened, and 
can be changed at any time.  Unlike the Data Browser, rows do 
not represent sentences or clauses.  Each column group (which 
has two columns-one for the term or phrase, one for the count 
of how many times that term or phrase appeared in the results) 
exists independently of the others. 

 Timeline—This tool displays the query results by extracted, 
document, or load dates.  The results may be further organized 
by different categories, like location or subject.  The records 
are then plotted on a timeline.  Records or their icons (which 
denote the type of result) may be clicked on for further 
information on that particular record. 

 Geo Display—This tool displays the query results by either 
inferred or explicit location in the result.  The results are 
plotted on a world map.  Areas on the map may be zoomed in 
on, and distances between points may be calculated among 
other utilities.  The plotted points may be clicked on for further 
information about that particular record. 

  Notebook: 
 New/Saved—This button opens a Notebook display (the 

system’s current default text editor).  From the display old 
Notebooks may be accessed.  Information from the query 
results may be copied into the notebook, and the user can add 
notes to that information. 

 Current—This drop-down list holds all the currently active 
Notebook displays (ones that were hidden and not closed).  
Selecting the particular display to view from the list and 
clicking the “Open” button next to the list may open these 
displays. 
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Appendix B 
Trace Through: 
Start at Main Menu 
 
1. Load Documents: 

Click this button on the Main Menu to choose the text documents to extract data 
from.  Once the data has been extracted, the Query tool can search through this data.  
To choose documents and extract data from them:   

• Open the Load Documents screen by clicking on the “Load Documents” 
button on the main menu 

• Select either Files or Directories to be loaded 
 Only files OR directories may be loaded, never both 

• In the dialog box that opens, find and select the document(s) to be added to 
the Load list and click “OK” to return to the Load Documents main screen 

• To remove a file or directory from the Load list, select the file/directory and 
click “Delete” 

• To save the documents being loaded as a new Load Group, type the name the 
group is to be saved under in the “Load Group” text box. 

• To add the documents being loaded to an existing Load Group, click “Select” 
under “Load Group,” choose the load group to add to and click “OK” to return 
to the Load Documents main screen 

• When finished, click “OK” to add the documents in the Load list  
 
2. Extraction Process Status: 

While the documents selected under Load Documents are loading, click this button 
on the Main Menu to view where each document is in the extraction process.  To 
view this data: 

• Click “Extraction Process Status” to view where in the extraction process 
loading documents are 

• Loading documents appear in a table.  Each column represents an extraction 
process, and in that column each document is either PENDING, RUNNING, 
or SUCCESSful. 

• To remove a document from the process, click “Delete Entries”, click “OK” in 
the pop-up box that appears telling you what to do, then select the document 
to be removed and click “Delete Entries” again. 

 
3. Term Organizations: 

New term organizations, or saved ones, are created and viewed under this tool.  
Words (terms) are organized into hierarchical groups in this tool.  These groups are 
used as query criteria in the Query tool.  
When a Term Organization is hidden, it can be displayed again by selecting the Term 
Organization name from the “Current” drop-down list under the Term Organization 
section. 
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• Click “New/Stored” under the Term Organization section of the Main Menu 
to open the Term Organization Manager 

• To create a new concept domain, under the “Data Store” menu select “New” 
• To open an existing concept domain, under the “Data Store” menu select 

“Open,” select the concept domain to be opened, and click “Open Data Store” 
• To close an open concept domain (more than one may be open at a time) 

under “Data Store” select “Close,” select the name of the concept domain to 
close, and click “Close Data Store” 

• To add a category to Entities, Actions, Attributes select the category the new 
category (or node) is to be placed under, and right-click the mouse.  Select 
Add Subnode from the pop-up menu, and type in the name of the new 
category.  DO NOT select Add Category.  When the name of the node is 
typed, click “OK” and it will appear under its “parent node” (the category it 
was placed into). 

• To remove a node from anywhere, select the category and hit the Delete key, 
or right-click and select Delete Nodes from the pop-up menu. 

• To add an ID Term select the node to add the term(s) to, and right-click the 
mouse.  Select Define, then ID Terms from the pop-up menu.  Type in the 
name of the first term to be added, and click Add.  Keep typing in terms and 
clicking Add until done and then click “OK”.  The number of terms entered 
will appear next to the node name. 

• To remove an ID Term select the node to remove the term(s) from, and right-
click the mouse.  Select Define, then ID Terms from the pop-up menu.  Select 
the name of the term(s) and click “Delete.”  Click “OK” to close the pop-up 
window. 

• To add a node to Concept select the Concept category to be added to, right-
click the mouse and select Add Subnode then select Concept, and type in the 
name of the node to be added.   

• To add an Event select the Concept category to be added to, right-click the 
mouse and select Add Subnode then select Event, and type in the name of the 
node to be added.   

• To remove an Event, select the Event and hit the Delete key, or right-click and 
select Delete Nodes from the pop-up menu. 

• To define an Event open the Event to be defined (it must be added to the 
Concept first), and select a category (Actor, Act, Affected, or Other) to define.  
Right-click the mouse, and select Define then Add Reference from the pop-up 
menu.  In the display that pops up, select the category you wish the event to be 
defined by.  Note that the display only shows categories for the specific part 
of the event (Entities for Actor and Affected, Actions for Act and Attributes 
for Other), and you can only choose what you have already defined in another 
category.  Not all the parts of the event need to be defined in order to create 
the event, however the more parts defined the more specific the search will be. 
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• To remove a definition in an Event open the Event to be changed, select the 
category to be undefined, right-click and choose Define then Remove 
Reference. Be sure that you want to remove the particular reference, as you 
get no question asking you if you are sure. 

 
4. Query Development: 

New queries are created with this tool.  In the query display, words or phrases may be 
entered, or term organizations can be used, as search criteria. The four available 
fields, Subject, Verb, Object, and Any, can be used in any combination to create a 
Concept.  Terms may be entered directly into the display by the user, or the groups 
created under the Term Organization tool may be used as search criteria.  Not all 
query fields must have information to search for, but the more information entered 
into the display the more specific the results returned will be. 
Once a query has been hidden, it can be displayed by selecting the query name from 
the “Current” drop-down list under the Query section. 

• Click on the New Query button to bring up an empty Query display. 
• To enter terms directly into the tool, under the field section to search enter the 

term(s) to be searched for in the top, white-colored text field. 
• Term Organization groups may be used by clicking the “Concept” button 

under the field section to add the group to.  In the dialog box that appears 
click “Add”.  This brings up the Term Organization tool.  Select the group(s) 
to add from this display. 

• To remove a term group from the search criteria, click the “Concept” button 
under the field section the unwanted term group is in.  Select the term 
group(s) from the dialog displayed, and click “Remove”.  All the term groups 
may be removed by clicking the “Clear” button on the Concept display. 

• To add an Entity Type to the search criteria (a specific type of entity to search 
for, such as organizations, locations, etc) select the “Entity” button under the 
field section to add to.  From the left side of the dialog box displayed choose 
the entity type(s) to be searched for and click “Add”.  The types will appear 
on the right side of the display.  Entity Types are not available for the Verb 
field. 

• To remove an Entity Type, click the “Entity” button, and in the dialog 
displayed select the entity type to remove from the right side of the display.  
Click “Remove” and the entity type is removed.  The “Reset” button on the 
Entity Type display clears all entity types from the search criteria for that 
field. 

• Under the Object field is the option to make its search criteria the same as the 
Subject field.  Checking the checkbox next to the Same as Subject label makes 
it so that both the Object and Subject field are searched for the information 
under the Subject field. 

• Fields may be cleared of all information by clicking the “Clear” button under 
that particular field. 
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• Fields may be hidden from view by clicking the “Less” button under the line 
of fields.  The Any field may be hidden, and the Subject, Verb, and Object 
fields may be hidden as well. 

• Locations may be specified to search for under the Location field.  Clicking 
the “Change” button displays a dialog where locations to be searched for may 
be entered.  The locations may be entered as either Political Divisions or 
Other.  Political Divisions use normalized country, subnational, and city 
names as search criteria.  The name(s) of the country, subnational, and/or city 
may be entered into their respective text fields, and each text field may be 
cleared by clicking the “Clear” button next to that particular field.  The Other 
section holds locations not normalized.  These locations are entered in the text 
field in the Other section of the Location display, and are cleared by clicking 
the “Clear” button next to the text field. 

• Dates to search for may be specified in the Date field.  Clicking “Change” 
brings up a date display where starting and ending dates may be chosen by 
clicking the “Between” button between the two calendar displays, and in those 
calendar displays selecting the starting and ending month, day and year.  The 
dates to search for may also be specified by only inputting the start OR end 
date, then clicking the +/- button beneath the calendar display inputted into 
and in the bottom inputting the amount of time to add (to the start date) or 
subtract (from the ending date).  Years, months, days, hours, and minutes may 
be entered as the amount of time differing from the start/end date.  The current 
date may also be used in the calendar displays by clicking the “Use Current 
Date” button above the calendar display. 

• The documents searched may be limited under the Document Limits field by 
clicking the “Change” button.  This displays a dialog box where document 
groups may be specified by clicking the “Add” button next to the Document 
Groups text field and selecting the document group(s) to search through.  
These groups may be removed by clicking the “Remove” button next to the 
Document Groups text field and selecting the group(s) to remove.  Document 
Date Range and Loaded Date Range may also be specified by clicking the 
“Change” button under the text field of the date range section.  This brings up 
the same display as the Date field displayed, and the dates may be chosen 
from this display. 

• When all the desired search criteria have been entered into the Query display, 
clicking the green “Run” button on top of the display runs the query.  A 
progress bar is shown above this button to show how far the query has 
searched.  When the query has finished running, the results may be sent to the 
Analysis and Visualization tools by clicking the eye icon on the toolbar. 

 
5. Analysis and Visualization Tools 

The A&V tools display query results in four different ways.  The document that a 
particular result came from can be accessed from each of these tools. 
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On the Main Menu, these tools are only available when there is a query hidden.  
When chosen from the Main Menu, they display the results from the query currently 
selected in the “Current” drop-down list in the Query section. 
To get the A&V tools from the query tool (or the data browser or statistics tool) click 
on the eye icon on the toolbar.  In the “Send Dataset” dialog box that appears choose 
which A&V tool to view.  Set the maximum number of results to view in that tool, 
and select which data type to view.  Simple Events sends the extracted data (verbs, 
subjects, etc), Sentences sends sentences, and Named Entities sends the proper nouns 
(names of people, organizations, locations, dates, etc) that were extracted.  Click 
“OK” to view the information through the selected display tool. 
5a. Data Browser:  

 Displays the query results in a table.  Each row represents a query result and each 
column is a specific part of that result.  To use the Data Browser: 

• The columns and categories shown in the Data Browser may be 
changed under the Options menu by clicking on the one you wish to 
change, then unchecking the categories or columns to hide and 
checking those to show.   

• Columns and the Category column may also be highlighted by 
category by choosing Color under the Options menu, and selecting to 
highlight the Category column, all the columns, or no highlighting.   

• Cells of the table may be changed by selecting “Allow Cell Editing” 
under the Edit menu, selecting the cell to alter and change it. 

• Unwanted or unneeded rows may be removed from the display (but 
not from the results sent to other tools) by selecting the row to take out 
and then selecting “Delete Selected Row” from the Edit menu. 

• All or selected rows may be sent to another A&V tool by selecting the 
rows to be sent (if all rows then this may be skipped), and clicking the 
eye icon or “Visualize” under the Files menu.  Choose either “All” or 
“Selected from the dialog box that appears (or “Document Browser” to 
view one document in full-text form).  This will bring up the “Send 
Dataset” dialog box. 

• One result may be sent to the Document Browser by selecting the 
result to view, clicking the eye icon or “Visualize” under the Files 
menu, and choosing “View Document” from the dialog box that 
appears.  The result can also be sent to the Document Browser by 
double clicking on it. 

5b. Statistics Tool: 
 Displays statistical information on the query results.  The different column pairs 

shown (each representing a different sentence-structural or informational part of 
the result) are chosen by the user.  These column pairs show the term/phrase 
found and the number of times it was found in the query results.  To use the 
Statistics Tool: 
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• When the tool starts up, choose which columns of information to be 
displayed.  The columns displayed may be changed at any time by 
selecting the “Show Columns” under the “Options” menu.  A dialog 
box will appear.  On the box check any columns to view and uncheck 
any columns to hide. 

• The minimum number of occurrences shown can be changed by 
selecting “Minimum Count” under the “Options” menu.  In the dialog 
box that appears type in the minimum number of results to show in the 
statistics display.  To show all results, type in “1” 

• To show how many results did not have an entry for the columns 
select “Show Empties” under the “Options” menu.  These blank rows 
may be hidden in the same way as they were shown. 

• To send all or selected rows to another A&V tool select the rows to be 
sent (if all rows then this may be skipped), and click the eye icon or 
“Visualize” under the Files menu.  Choose either “All” or “Selected 
from the dialog box that appears.  This will bring up the “Send 
Dataset” dialog box. 

5c. Timeline: 
Displays the query results by date (extracted, document, or load date) on a 
timeline.  Results may be further organized on the timeline by grouping results 
into a category chosen by the user.  Once plotted on the timeline, information on a 
specific result may be viewed by clicking on it.  To use the Timeline: 

• Select the type of dates to be plotted from the dialog box that appears 
when the timeline tool is opened.  The types are extracted (from the 
specific clause), document (I have no idea), or load (when the 
information was extracted through the program) dates.  The option to 
use an inferred date, which the program assigns to a result, is also on 
this dialog box. 

• Select what the results will be grouped by from the list that appears in 
the second dialog box and click “OK”.  If no grouping is desired, 
select “None.” 

• When the results are finished a dialog box will appear with 
information on how many results were plotted, and why the rest of the 
results weren’t plotted. Click “OK” to close this screen 

• Clicking on a button in the row of date buttons on the top of the 
timeline will display only the events in that time (decade, year, etc.) 

• Left clicking on an icon or a result opens an “External Event” dialog 
box, which shows information about that particular event. 

• To select a group of events, left-click and drag to box the events to be 
selected.  Right-click on any of the selected events to send those 
events to another A&V tool.  To do so, select “Visualize Data” from 
the menu that appears, and choose “All” or “Selected” from the dialog 
box that appears.  This will bring up the “Send Dataset” dialog box.   



 

 21

• One result may be sent to the Document Browser by right clicking on 
the result to view and choosing “View Document” from the menu that 
appears. 

 5d. GeoDisplay Tool: 
Displays the query results by location on a world map.  Results may be clicked on 
to display further information on that result plotted and different map utilities (for 
example calculating distances) are available.  To use the Geo-Display Tool:  

• Answer the “Plot Inferred Locations” question that appears when the 
GeoDisplay tool is opened to choose whether or not to display only 
locations explicitly stated in the extracted information. 

• When the locations are finished plotting an information box will 
appear displaying the results sent, plotted, and the reason why the rest 
of the results were not plotted. 

• Left clicking on an icon on the map will display extracted information 
on the result that icon represents on the bottom of the screen.  Right-
click to end this mode. 

• Click on the “Utilities” menu to view and use the Utilities dialog box 
• On the dialog box, clicking “Recenter” then clicking on a region of 

the map will center the map around that region. 
• The “Prev Map” button on the Utilities dialog box returns the map 

to its previous view. 
• To calculate distances between two points on the map, click “Calc 

Dist” on the Utilities dialog box, and click on the two points to see 
the distance between them displayed in several different formats 
on the bottom of the screen. 

• Zooming in on an area of the map is accomplished by clicking 
“Box Area” on the Utilities dialog box, selecting one corner of the 
area to zoom in on, then selecting the opposite corner (a box will 
appear as the mouse moves to show which area will be zoomed in 
on). 

• To find a country or area by its name click on the “Show Area” 
button on the Utilities dialog box.  In the box that appears type the 
name of the country or area into the text field and click “OK.”  To 
return to a worldview, type in “world”. 

• To send the results to another A&V tool, right-click anywhere on the 
map area to display the “Send Dataset” dialog box. 

• To view a result’s document, right-click on that result and select 
“View Document” from the question box that pops up.   

5e. Document Browser 
• To view the categories that correspond to the highlighting colors, 

under the “Files” menu select “Categories.”  This will bring up a table 
of the categories, highlighted by their corresponding colors, and the 
number of times the categories appear in the open document. 
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6. Previous Queries (Topics): 
Queries can be saved from the Query tool, or from any of the visualization tools.  
Saved queries can also be accessed by opening this tool from the Main Menu. 
When “Save” is selected from any of the visualization tools or the query tool, it opens 
up the Saved Query Results dialog box.  The dataset, or query information, is saved 
temporarily under “Working Data,” and unless moved to “User Data” will be deleted 
when the tool is closed.     

• To move the dataset, select the name it was saved as under “Working Data” 
(the names of temporarily saved datasets appear under the “Element:” section 
when Working Data is selected), and use the icons on the toolbar to Cut 
(scissors) or Copy (two sheets of paper) the dataset.  Then, under User Data, 
select the file and folder to save the dataset under, then click the Paste (paper 
with clipboard) icon on the toolbar.  The Cut, Copy, and Paste options can 
also be found under the “Edit” menu, or by right-clicking on the items rather 
than just selecting them, and selecting the option to use from the menu that 
appears. 

• Datasets, folders and topics may be moved between displays (each display is 
its own file on the computer) by using the cut, copy, and paste utilities.  New 
displays can be created under the “File” menu by selecting “New.”  Save the 
current display if desired when the pop-up box asks, and the new display will 
open. 

• Displays may be saved under the “File” menu by selecting “Save” or “Save 
As,” or by clicking the save icon (closed file cabinet) on the toolbar. 

• Previously saved displays can be opened by clicking on the open icon (opened 
file cabinet) or under the “File” menu by clicking “Open,” and finding and 
selecting the display to open from the dialog box that appears. 

• Under User Data, saved datasets can be organized into a hierarchy of topics 
(cabinet drawers) and elements (folders).  To create a topic, right-click on 
User Data or the topic the new topic is to be saved under.  Select “New 
Topic,” name the topic in the dialog box that pops up and the topic is created.  
Elements (folders) are created in the same way, by clicking on “New 
Element” instead of “New Topic.”  New topics and elements may also be 
added by selecting the item to add to, and under the “Edit” menu selecting 
“New” and then the type of item to be added.  Elements can be added to User 
Data or any topics, but only datasets may be added to an element.  

• The topic and element sections under User Data may be hidden (collapsed) or 
viewed (expanded) by clicking on the plus or minus sign next to the icons 
(plus will expand the item, minus will collapse it).  Right-clicking the item 
and choosing “View” and then either “Expand Folder” or “Collapse Folder” 
from the menus that appear accomplishes the same thing.  All topics may be 
expanded or collapsed under the “View” menu and selecting either “Expand 
All Topics” or “Collapse All Topics.” 
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• Information about the datasets is displayed under the “Dataset:” section by 
selecting the dataset under “Element” when the element folder is selected.  
The same information is displayed by clicking the “i” icon on the toolbar 
when the particular dataset is selected, or by right-clicking on the dataset and 
choosing “Item Information” from the menu that appears.  Another way to 
view the information is by selecting the item and then selecting “Item 
Information” under the “View” menu.   

• Topics, elements and datasets may be deleted by selecting the items to be 
deleted and clicking the delete (circle with a line through it) icon on the 
toolbar or by selecting “Delete” from the “Edit” menu. A “Delete” option can 
also be found by right clicking on the item and selecting “Delete” from the 
menu that appears. Only items under User Data or Query Tool may be 
deleted.   

• The Undo icon (arrow going in a circle) on the toolbar reverses the last action 
performed.  The last action may be undone by selecting “Undo” under the 
“Edit” menu, or an Undo option can be found by right clicking on any item in 
the display. 

• To open up help on the Saved Query Results click on the question mark icon 
or the Help menu. 

6a.  To open and run a saved query, or change the saved dataset, select the Saved Queries 
       button on the Main Menu and: 

• The saved dataset may be changed by selecting the dataset, then clicking the 
Edit (paper with pencil) icon on the toolbar or by right-clicking on the dataset 
and selecting “Edit Dataset”.  In the dialog that pops up, clicking “Set 
Parameters” will bring up the query screen with all the query information 
saved.  From there, the query may be changed.   

• The datasets may be sent to the visualization tools by selecting the particular 
dataset and either clicking the Visualize (eye) icon on the toolbar, choosing 
“Send Dataset” from the “Tools” menu; or by right-clicking on the dataset and 
choosing “Send Dataset.” 
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Appendix C: Button Comments Table 
 

Section/Button Comment 
Setup and Extraction Processes  
     Loading and Extraction Processes  
          Load Documents Choose files or documents to extract data from 
          Extraction Process Status View where loading documents are in the extraction 

process, remove loading documents 
     Concept Development  
          New/Stored Create or change a saved term organization (concept) 
          Current (drop-down list) Currently open/active concepts (term organizations). To 

display comments on a current term organization, select it 
from the list. 

     Previous Queries  
          Saved Query Results Open and organize saved queries and query results 
Search Processes  
     Query Development  
          New Query Create a new query to search extracted data 
          Current Currently open/active queries.  To display comments on a 

current query, select it from the list. 
     Analysis and Visualization  
          Data Browser View table of extracted data from query results 
          Statistics View statistical information on query results--how often 

particular terms occurred 
          Timeline View query results plotted on a timeline by extracted 

date/time 
          Geo-Display View query results plotted on a world map by extracted 

locations 
          Current  Currently open/active analysis and visualization displays 
     Notebook  
          New/Saved Open text window to copy information from documents, 

and write notes on queries 
          Current Currently open/active note windows. To display comments 

on a note window, select it from the list. 
About Displays a window containing information about the 

creators and the version of IAA 

Help Displays a pop-up box of information about the IAA 
System 

Exit Closes the program 
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Appendix D: Help Screens Table 
 

Tool: Help: 
Main Menu Welcome to Intelligence Analyst Associate 

 
IAA takes text documents and extracts sentence 
structural information out of them (nouns, verbs, 
etc.).  To do this, IAA uses state-of-the-art natural 
language understanding.  After extraction, the user 
may query the extracted data to find specific data in 
documents.    
   
Setup and Extraction Process: 
To load documents, click the Load Documents 
button.  The Extraction Process Status will show 
where documents are in the extraction process.  
While documents are loading, the user may create a 
Term Organization, to use to query the loaded 
documents for the terms in the organization.  
Previous Queries allows for a particular query to be 
run on different documents without having to 
reconstruct that query each time. 
     
Search Processes: 
Query Development, of course, allows the user to 
determine what to search for in the documents once 
they are loaded.  After running a query, the Analysis 
and Visualization tools may be used to view the 
results in various manners.  Notes on the query 
results can be written in the Notebook. 
     
Each section in IAA has its own help file.  If more 
help is required, see the user's manual and the trace-
through. 

Load Documents Documents may be selected to load as files or as 
whole directories (a group of files in the computer), 
but not as both.  Click the corresponding button to 
select and add documents to the load list.  
 
Documents to be loaded may be named as a Load 
Group, which makes it easier to query just those 
documents.  The group may be named by typing in 
a name in the “Load Group” text box.  Documents 
may also be added to existing load groups by 
selecting the load group from the “Select” button in 
the “Load Group” section. 

Load Status Information on where the documents selected from 
Load Documents are in the extraction process.  
Documents are either pending, running or 
successful in each stage.  Documents can be 
removed from the process at any point in the 
process. 
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Tool: Help: 
Concept Development Create organizations of terms to search for in the 

extracted data (from the documents selected in Load 
Documents).  Terms can be Entities (Actors, people, 
objects, or things), Actions (Acts, verbs, what the 
entities did), or Attributes (any other terms to be 
searched for, in any field). 
 
Terms may also be organized into Concepts, which 
are made of Events.  Events define the Actor (who, 
chosen from Entities), the Act (did what, chosen 
from Entities), the Affected (to whom, chosen from 
Entities), and Other (anything else to be searched 
for, chosen from Attributes).  Not all parts of an 
Event need to be defined, but the more definition an 
Event is given the more specific the results returned 
from the query are. 

Previous Queries Store and organize query results (a.k.a. datasets).  
When saved from the query tool, the dataset appears 
under “Query Tool.”  The dataset must be moved to 
a drawer or folder under “User Data” to 
permanently save the dataset.  Once saved, the 
query results may be sent to any of the analysis and 
visualization tools. 

Query Development ****************************************** 
Wait to view/use new interface before creating help 
pop-up 
****************************************** 

Data Browser Displays the query results in a table of extracted 
data (simple events), sentences, or named entities 
(people, places, organizations, locations, etc.).   
 
Columns may be hidden or viewed, and rows or 
categories (the types of information in the record) 
may be highlighted.  The cells in the table may also 
be edited. 

Statistics Displays statistical information on the number of 
times terms or clauses appear in query results.  The 
columns displayed are chosen by the user, and can 
be changed at any time.  The columns may be sorted 
alphabetically or by number of occurrences. 

Timeline Displays query results on a timeline.  Results are 
placed on the timeline based on extracted dates, 
loaded dates, or document dates.  Results can also 
be grouped together by different categories (for 
example, location or type of information). 
 
Information about a specific result can be accessed 
by double clicking on the result.  The icon next to 
the result denotes the category (type of 
information). 
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Tool: Help: 

Geo Display Displays query results by location on a world map. 
 
Information about a specific result may be viewed 
by double clicking on the result.  Areas on the map 
may be zoomed in on, distances can be calculated, 
and the map can be re-centered, among other 
available utilities. 

Document Browser Displays full-text documents a result was taken 
from.  Sentences/clauses are highlighted by 
category, and the sentence/clause the document 
browser was opened from is highlighted in yellow. 

Notebook Cut and paste information from the data browser, 
statistics, and document browser, add notes to the 
information, and save to a folder/directory on the 
computer for future access. 

 
 




